Issues with a core router.

Incident Report for 2talk

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 16:08 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2026 - 15:58 PST

Update

- Start Time: ~08:17
- Region: United States

Impact: Partial service disruption

Summary:
We experienced a service disruption in the US platform due to an underlying infrastructure hardware fault.

Current Status:
- A core part of the network is impacted
- Recovery actions for affected infrastructure are ongoing.
- No data loss has been identified.

Actions Taken:
- Isolated the affected infrastructure
- Continued remediation to ensure platform stability

Next Update:
Further updates will be provided as recovery is completed or if status change.
Posted Jan 20, 2026 - 13:47 PST

Identified

Our engineering team has identified the issue and is actively working to restore full performance.
Posted Jan 20, 2026 - 13:44 PST

Investigating

We are experiencing issues with a core router.
Posted Jan 20, 2026 - 13:41 PST
This incident affected: 2talk Calling Platform (Network), 2talk Cloud PBX, Mobile app, and Desktop app.